This is a sub-page of Beetle Adventure Racing!/The Untold Content?.

(Write down the plugin 'n emulator issues here. There's plenty of issues. Includes real hardware too!)

Common issues[redigera | redigera wikitext]

Issues that are shared by multiple plugins.

Fog[redigera | redigera wikitext]

Demonstration fog (example) Most? plugins
BeetleDerbyExampleFog.png BeetleFogGraphicalIssue.png

Most plugins don't seem to be able to emulate the fog properly. Black lines will partially cover the screen (but not the display).

Even plugins that can render fog might have some issues with it.

In some cases, the entire screen (still not including the display) is covered in black.

Rendering[redigera | redigera wikitext]

Depending on the plugin, certain entities may not render. It's also possible for an entity to not render even when it normally should.

Sun[redigera | redigera wikitext]

As it should look like Plugins that don't render it
BeetleTestRoadSun.png BeetleNoSun1.png

Some of the tracks in the game have a sun present. However, not all plugins render it.

Weird bar[redigera | redigera wikitext]

BeetleInfernoIsleWeirdBar.png

Some textures or places have some weird bar present. In the case of Inferno Isle, they allow the player to see where the invisible walls are in the fortress area.

Others[redigera | redigera wikitext]

Track identification screen[redigera | redigera wikitext]

xx As it should look like
BeetleDerbyIntroCameraWrongSpot.png BeetleDefaultTrackIdentify.PNG

If you start a race from the debug menu right away without choosing any of the options on the very first screen, the intro camera shows... well, nothing. This hasn't been confirmed to happen on real hardware, though (this section will remain here at least until we know for sure).

Menus[redigera | redigera wikitext]

The slide film effect when you go from one menu to another doesn't render in most plugins. Either it just sends you to the menu or the screen turns black for a second.

Speed display[redigera | redigera wikitext]

BeetleDerbySpeedDisplayWeirdBar.png

A transparent bar (whose visual appearance varies depending on the player's position, the current track etc.) usually appears on the speed display texture. While plugins like Glide64 For PJ64: 2.0.0.5 don't have the issue, its "successor" GLideN64 reintroduces it for some reason.

Plugins[redigera | redigera wikitext]

Hmmm...
To do:
Add more plugins.

Real hardware[redigera | redigera wikitext]

Technically considered a plugin in this case.

If a GameShark is attached, depending on what you use to record, the sound of the Beetle's engine might make a noise it normally doesn't make. Although this can also happen even without a GameShark.

angrylion's RDP with OpenGL 1.5[redigera | redigera wikitext]

This plugin is supposed to be like real hardware (right?), but issues exclusive to it can't be ruled yet.

xx

Glide64 For PJ64: 2.0.0.5[redigera | redigera wikitext]

The clouds of Coventry Cove are not rendered.

Fog is rendered, but trees have some sort of transparent square that disappears when you get close enough.

GLideN64[redigera | redigera wikitext]

xx

Jabo's Direct3D6 1.5.2[redigera | redigera wikitext]

Tree walls and trees are flat (menu track models are an exception) but render the texture itself correctly. This allows the player to see the big invisible walls close to the casino in Metro Madness.

The signs use the black color instead of dark blue.

Beetles don't look like they are supposed to be.

Menu track model 3 Inferno Isle
BeetleMenuTrackModel3WoodBridgeUntextured.png BeetleInfernoIsleWoodBridgeUntextured.png

The wood bridge in Inferno Isle is untextured for some reason.

Jabo's Direct3D8 1.6[redigera | redigera wikitext]

BeetleTreesNoGreenColor.png

The green color on the tree textures doesn't render, making all tree and tree walls white.

Certain textures don't render and are replaced by other ones.

Beetles don't look like they are supposed to be.

Jabo's Direct3D8 1.7.0.57-ver5[redigera | redigera wikitext]

BeetleSignsMessedUpTexture.png

The big signs found in some places in the game are messed up. The reason is unknown.

BeetleMetroMadnessBuildingTextureJabo'sDirect3D81.7.0.57-ver5.png

The buildings in Metro Madness and Rooftops look somewhat different from what they're supposed to look like. Even the tower in Airport (it uses the same texture) is affected.

Rice's Video Plugin 5.5.1[redigera | redigera wikitext]

The visual appearance of the Beetles are the same as in Jabo's Direct3D6 1.5.2.

xx (VanaSWE's two ProBook 6360b:s)[redigera | redigera wikitext]

Due to the issues with these two, screenshots are not taken from them except in certain situations when there is no other option or if it is necessary to explain the issues themselves. If there is no other option, mark them with a red square in the top left corner and replace them as soon as possible.

The cause of these issues is unknown.

BeetleProBookGraphicalIssue1.png

Certain models like Beetles look different from what they're supposed to look like.

BeetleCoventryCoveVanalkerProbookLayerDemonstrate.png

There seems to be some kind of layer that when you are close, it slightly moves.

BeetleProBookExitGridNoAppear.png

Certain elements like the exit grid in the arenas don't appear at close range. When in battle (at least in Airport), the exit grid doesn't visually appear at all.

Community content is available under CC-BY-SA unless otherwise noted.